Resource exhaustion in Imagemagick
CVE-2026-93587
ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy limit, causing a limited availability impact. The issue is fixed in 7.1.2-31 and 6.9.13-56.
Vulnerability class: DoS (Denial of Service)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 3.3 (Low). Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L.
EPSS exploit prediction
EPSS: 0.001 (1.9th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 2nd percentile — 1.9% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.001 · newest: 0.001 · change: +0.000
Affected products
Weakness classification (CWE)
References
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-89wq-f8f6-2j2v (vendor-advisory, Vendor Advisory)
- www.vulncheck.com/advisories/imagemagick-before-7.1.2-31-policy-bypass-via-pcd-… (Third Party Advisory, third-party-advisory)
Frequently asked questions
- What is CVE-2026-93587?
- CVE-2026-93587 is a low-severity vulnerability in Imagemagick, classified under Uncontrolled Resource Consumption. CVSS score: 3.3/10. Published 2026-09-18.
- How severe is CVE-2026-93587?
- Low severity. CVSS v3 base score is 3.3 out of 10.