Vulnerability in Nm-L2tp Networkmanager-L2tp
CVE-2026-93337
NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains an improper input validation vulnerability that allows local users with VPN connection creation permissions to inject arbitrary pppd directives by supplying mru or mtu property values containing trailing non-numeric content after a valid integer. Attackers can exploit the verbatim write of unvalidated strings into the pppd options file via write_config_option() to inject the plugin directive, causing the privileged pppd process to load an attacker-controlled shared object and achieve arbitrary code execution as root.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.8 (High). Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.
EPSS exploit prediction
EPSS: 0.001 (4.0th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 4th percentile — 4.0% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.001 · newest: 0.001 · change: 0.000
Affected products
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-93337?
- CVE-2026-93337 is a high-severity vulnerability in Nm-L2tp Networkmanager-L2tp, classified under Argument Injection. CVSS score: 7.8/10. Published 2026-09-17.
- How severe is CVE-2026-93337?
- High severity. CVSS v3 base score is 7.8 out of 10.