Privilege escalation in Patriksimek Vm2
CVE-2026-92958
vm2 through 3.11.6 contains a builtin-module denylist bypass in NodeVM. When the embedder uses the builtin wildcard together with negative entries (e.g. require: { builtin: ['*', '-fs', '-child_process'] }), negative entries are matched by exact module name in lib/builtin.js, so -fs removes only the builtin named fs and does not remove builtin subpaths such as fs/promises. Sandboxed code can therefore call require('fs/promises') or require('node:fs/promises') and reach the promise-based filesystem API despite fs being denied; node: prefix handling is likewise inconsistent (a -node:fs/promises entry does not block require('fs/promises')). Host file creation and writing were confirmed via fsp.writeFile(), and other fs/promises operations (cp, mkdir, rename, rm, rmdir, truncate, read operations, etc.) are also reachable. This issue is fixed in vm2 3.11.7.
Vulnerability class: Privilege Escalation
Published · last modified .
CVSS v3 metric
CVSS v3 base score 8.5 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:L.
EPSS exploit prediction
EPSS: 0.004 (32.5th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 33rd percentile — 32.5% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.004 · newest: 0.004 · change: 0.000
Affected products
Weakness classification (CWE)
References
- github.com/patriksimek/vm2/security/advisories/GHSA-6rh5-qq4q-97xh (vendor-advisory)
- www.vulncheck.com/advisories/vm2-before-3.11.7-denylist-bypass-via-fs-promises (third-party-advisory)
Frequently asked questions
- What is CVE-2026-92958?
- CVE-2026-92958 is a high-severity vulnerability in Patriksimek Vm2, classified under Improper Privilege Management. CVSS score: 8.5/10. Published 2026-09-17.
- How severe is CVE-2026-92958?
- High severity. CVSS v3 base score is 8.5 out of 10.