Vulnerability in Patriksimek Vm2
CVE-2026-92951
vm2 before 3.11.7 contains an incorrect authorization vulnerability in the external package allowlist check that uses non-exact substring matching instead of full package-name boundary validation. Attackers can bypass the allowlist by requiring a colliding package name that contains an allowlisted package substring, causing vm2 to load and execute unauthorized host packages in the host context.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 9.9 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H.
EPSS exploit prediction
EPSS: 0.005 (40.5th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 40th percentile — 40.5% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.005 · newest: 0.005 · change: -0.001
Affected products
Weakness classification (CWE)
References
- github.com/patriksimek/vm2/security/advisories/GHSA-c48m-32m9-vx93 (vendor-advisory)
- www.vulncheck.com/advisories/vm2-before-3.11.7-module-allowlist-bypass-via-cust… (third-party-advisory)
Frequently asked questions
- What is CVE-2026-92951?
- CVE-2026-92951 is a critical-severity vulnerability in Patriksimek Vm2, classified under Use of Incorrectly-Resolved Name or Reference. CVSS score: 9.9/10. Published 2026-09-17.
- How severe is CVE-2026-92951?
- Critical severity. CVSS v3 base score is 9.9 out of 10.