XSS in Apache Sling Xss Protection API
CVE-2026-91928
Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Sling XSS. This issue affects Apache Sling XSS: before 2.4.12. Users are recommended to upgrade to version 2.4.12, which fixes the issue.
Vulnerability class: XSS (Cross-Site Scripting)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 6.1 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N.
EPSS exploit prediction
EPSS: 0.006 (47.4th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 47th percentile — 47.4% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.004 · newest: 0.006 · change: +0.002
Affected products
Weakness classification (CWE)
References
- lists.apache.org/thread/yfb1q6zob8mth5lr4jnsy3lhx9rfwb02 (vendor-advisory, Mailing List, Vendor Advisory)
- af854a3a-2127-422b-91ae-364da2661108 (Mailing List, Third Party Advisory)
Frequently asked questions
- What is CVE-2026-91928?
- CVE-2026-91928 is a medium-severity vulnerability in Apache Sling Xss Protection API, classified under Cross-site Scripting. CVSS score: 6.1/10. Published 2026-09-23.
- How severe is CVE-2026-91928?
- Medium severity. CVSS v3 base score is 6.1 out of 10.