Buffer overflow in Luben Zstd-Jni

CVE-2026-90852

A vulnerability has been found in luben zstd-jni up to 1.5.7-13. This vulnerability affects the function ZstdCompressCtx.loadDict of the file ZstdCompressCtx.java of the component Dictionary Sharing. Such manipulation leads to use after free. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.5.7-14 is able to resolve this issue. The name of the patch is a560131d7834598afd9cea6b7c107bc88e915936. The affected component should be upgraded. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Vulnerability class: Buffer Overflow

Published · last modified .

CVSS v3 metric

CVSS v3 base score 7.3 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L.

EPSS exploit prediction

EPSS: 0.005 (45.3th percentile), scored .

Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 45th percentile — 45.3% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2026-90852: held from 0.005 to 0.005.

EPSS over last 30 days · oldest: 0.005 · newest: 0.005 · change: 0.000

Affected products

Weakness classification (CWE)

References

Frequently asked questions

What is CVE-2026-90852?
CVE-2026-90852 is a high-severity vulnerability in Luben Zstd-Jni, classified under Improper Restriction of Operations within the Bounds of a Memory Buffer. CVSS score: 7.3/10. Published 2026-09-15.
How severe is CVE-2026-90852?
High severity. CVSS v3 base score is 7.3 out of 10.