Buffer overflow in Ffmpeg

CVE-2026-90815

A vulnerability has been found in FFmpeg up to 4.4.6/5.1.8/6.1.4/7.1.3/8.0.1. Affected by this issue is the function setup_3x3 of the file libavfilter/vf_convolution.c of the component Convolution Filter. Such manipulation leads to out-of-bounds read. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.4.7, 5.1.9, 6.1.5, 7.1.4, 8.0.2, 8.1.1 and 9.0 can resolve this issue. The name of the patch is 8970658472/e24b9820b4. It is suggested to upgrade the affected component.

Vulnerability class: Buffer Overflow

Published · last modified .

CVSS v3 metric

CVSS v3 base score 6.3 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L.

EPSS exploit prediction

EPSS: 0.004 (36.6th percentile), scored .

Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 37th percentile — 36.6% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2026-90815: held from 0.004 to 0.004.

EPSS over last 30 days · oldest: 0.004 · newest: 0.004 · change: 0.000

Affected products

  • Ffmpeg — versions 4.4.0, 4.4.1, 4.4.2

Weakness classification (CWE)

References

Frequently asked questions

What is CVE-2026-90815?
CVE-2026-90815 is a medium-severity vulnerability in Ffmpeg, classified under Improper Restriction of Operations within the Bounds of a Memory Buffer. CVSS score: 6.3/10. Published 2026-09-14.
How severe is CVE-2026-90815?
Medium severity. CVSS v3 base score is 6.3 out of 10.