Auth bypass in Wp-Graphql
CVE-2026-88974
WPGraphQL provides a GraphQL API for WordPress sites. Prior to 2.22.2, the updatePost mutation in src/Mutation/PostObjectUpdate.php checks only the collection-level edit_posts capability and the post author, but does not enforce the object-level edit_post capability or require publish_posts for public status transitions. An authenticated Contributor can therefore publish the Contributor's own draft without editorial approval or modify the Contributor's previously published post despite lacking edit_published_posts, while posts owned by other authors remain protected. This issue is fixed in version 2.22.2.
Vulnerability class: Broken Access Control
Published · last modified .
CVSS v3 metric
CVSS v3 base score 5.4 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L.
EPSS exploit prediction
EPSS: 0.004 (32.0th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 32nd percentile — 32.0% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.003 · newest: 0.004 · change: +0.001
Affected products
- Wp-Graphql — versions < 2.22.2
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-88974?
- CVE-2026-88974 is a medium-severity vulnerability in Wp-Graphql, classified under Incorrect Authorization. CVSS score: 5.4/10. Published 2026-09-23.
- How severe is CVE-2026-88974?
- Medium severity. CVSS v3 base score is 5.4 out of 10.