Improper input validation in Backstage
CVE-2026-88064
Backstage is an open framework for building developer portals. Prior to 1.14.6 and from 1.15.0 until 1.15.4, the @backstage/plugin-techdocs-node package insufficiently validates mkdocs.yml supplied by an authenticated user who can register or modify a TechDocs source. Unsafe Python YAML tags, markdown_extensions names and configuration, theme options, and extra_templates values can reach the documentation generator and cause unintended code execution. The resulting impact is limited to the files, credentials, network access, and other resources available to the TechDocs backend or build container. This issue is fixed in versions 1.14.6 and 1.15.4.
Vulnerability class: Drupalgeddon 2 (CVE-2018-7600)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 8.8 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.
EPSS exploit prediction
EPSS: 0.012 (67.7th percentile), scored .
Low probability of exploitation in the next 30 days, but still tracked. 68th percentile — 67.7% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.009 · newest: 0.012 · change: +0.003
Affected products
- Backstage — versions < 1.14.6, >= 1.15.0, < 1.15.4
- Linuxfoundation Backstage
- Linuxfoundation Backstage Plugin-Techdocs-Node
Weakness classification (CWE)
References
- github.com/backstage/backstage/security/advisories/GHSA-292q-8mf5-h6g3 (Mitigation, Vendor Advisory)
- github.com/backstage/backstage/commit/017ace52d9b327ededc6704cf17799c875ae0f29 (Patch)
- github.com/backstage/backstage/commit/02cd7cdbb18b687446277b5602adaee7f1d53cbb (Patch)
- github.com/backstage/backstage/commit/25125ee727a3de3418a8fa6a9e458cd5b73ecf26 (Patch)
- github.com/backstage/backstage/commit/a7d995f11a5d27f0efbdbe8bb6c21b06988c79c9 (Patch)
- github.com/backstage/backstage/commit/a900a9953c8f7ad3ba1906d1d257725a9996cc9d (Patch)
- github.com/backstage/backstage/releases/tag/v1.50.5 (Patch, Release Notes)
- github.com/backstage/backstage/releases/tag/v1.54.6 (Patch, Release Notes)
Frequently asked questions
- What is CVE-2026-88064?
- CVE-2026-88064 is a high-severity vulnerability in Backstage, classified under Improper Input Validation. CVSS score: 8.8/10. Published 2026-09-16.
- How severe is CVE-2026-88064?
- High severity. CVSS v3 base score is 8.8 out of 10.