Vulnerability in Apache Tomcat Native
CVE-2026-86247
Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.4 (High). Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N.
EPSS exploit prediction
EPSS: 0.002 (10.2th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 10th percentile — 10.2% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.002 · newest: 0.002 · change: -0.000
Affected products
Weakness classification (CWE)
References
- lists.apache.org/thread/obsson6zhvfg0wsp2bx602l61ltj87r1 (vendor-advisory, Vendor Advisory)
- af854a3a-2127-422b-91ae-364da2661108 (Mailing List, Third Party Advisory)
Frequently asked questions
- What is CVE-2026-86247?
- CVE-2026-86247 is a high-severity vulnerability in Apache Tomcat Native, classified under Race Condition within a Thread. CVSS score: 7.4/10. Published 2026-09-23.
- How severe is CVE-2026-86247?
- High severity. CVSS v3 base score is 7.4 out of 10.