RCE in Perforce Software Puppet Enterprise

CVE-2026-85979

Affected versions of Puppet Enterprise contain a command injection vulnerability. An authenticated user with Puppet administrative privileges can inject arbitrary shell commands by providing a specially crafted value for this parameter, which is passed to a shell execution context without sufficient sanitization. Because the resulting commands are executed with root privileges, successful exploitation can lead to full compromise of the affected system.  It affects Puppet Enterprise 2023.8.0 through 2023.8.10 and Puppet Enterprise 2025.0.0 through 2025.11.2. This has been resolved in Puppet Enterprise 2023.8.11 and Puppet Enterprise 2025.11.3.

Vulnerability class: Drupalgeddon 2 (CVE-2018-7600)

Published · last modified .

EPSS exploit prediction

EPSS: 0.013 (69.9th percentile), scored .

Low probability of exploitation in the next 30 days, but still tracked. 70th percentile — 69.9% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2026-85979: held from 0.013 to 0.013.

EPSS over last 30 days · oldest: 0.013 · newest: 0.013 · change: 0.000

Affected products

Weakness classification (CWE)

References