Vulnerability in Pocketbase
CVE-2026-82410
Pocketbase is an open source web backend written in go. Prior to 0.22.48 and 0.39.7, PocketBase's panic-recovery middleware covers regular request handling but not internal child and worker goroutines. A panic in one of these internal goroutines can escape recovery and terminate the server process, causing a denial of service. The remediation introduces routine.SafeWrap to convert recovered panics into regular errors and applies it to the affected internal worker functions. This issue is fixed in versions 0.22.48 and 0.39.7.
Published · last modified .
EPSS exploit prediction
EPSS: 0.006 (47.5th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 48th percentile — 47.5% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.006 · newest: 0.006 · change: 0.000
Affected products
- Pocketbase — versions < 0.22.48, >= 0.23.0, < 0.39.7
Weakness classification (CWE)
References
- github.com/pocketbase/pocketbase/commit/30b4184305904fae0d1b78216c4e3cc34700b220
- github.com/pocketbase/pocketbase/commit/f1618ee59b6d1c0308bb474c827a2b1f24b12a95
- github.com/pocketbase/pocketbase/discussions/7762
- github.com/pocketbase/pocketbase/releases/tag/v0.22.48
- github.com/pocketbase/pocketbase/releases/tag/v0.39.7
- github.com/pocketbase/pocketbase/security/advisories/GHSA-84vh-m24q-wjjx