Vulnerability in Apache Apache-Airflow-Providers-Fab
CVE-2026-82311
Apache Airflow FAB provider: resetting a user's password does not delete that user's existing database-backed sessions, despite documented behaviour that it does. The cleanup compares the string identifier Flask-Login stores in the session against the user's integer database identifier, so the comparison never matches and no session is removed. An attacker who already holds a copy of the victim's session cookie keeps access as that user after the password change, so the reset does not evict them. Affects deployments using the FAB auth manager with `[fab] session_backend=database`. The trigger is an administrator (or the user) running the supported password-reset command as a containment action after a session cookie has been compromised; the secure-cookie backend is out of scope, as it documents that it cannot centrally delete sessions. apache-airflow-providers-fab 3.9.0 also fixes CVE-2026-86462, a second, independent route to the same outcome via the Admin user-edit endpoint; a single upgrade closes both. Users of apache-airflow-providers-fab are recommended to upgrade to version 3.9.0 or later, which compares the identifiers consistently.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 9.8 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.
EPSS exploit prediction
EPSS: 0.010 (62.1th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 62nd percentile — 62.1% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.010 · newest: 0.010 · change: 0.000
Affected products
Weakness classification (CWE)
References
- github.com/apache/airflow/pull/72198 (Patch, patch, Vendor Advisory)
- lists.apache.org/thread/mmplwl93shy615shkpp9p4fzyjvr4yqw (vendor-advisory, Mailing List, Vendor Advisory)
- www.cve.org/CVERecord (related, Third Party Advisory)
- lists.apache.org/thread/mmplwl93shy615shkpp9p4fzyjvr4yqw (vendor-advisory, Mailing List)
Frequently asked questions
- What is CVE-2026-82311?
- CVE-2026-82311 is a critical-severity vulnerability in Apache Apache-Airflow-Providers-Fab, classified under Insufficient Session Expiration. CVSS score: 9.8/10. Published 2026-09-16.
- How severe is CVE-2026-82311?
- Critical severity. CVSS v3 base score is 9.8 out of 10.