Vulnerability in Rabbitmq Amqp091-Go
CVE-2026-77405
RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.
Published · last modified .
EPSS exploit prediction
EPSS: 0.003 (20.7th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 21st percentile — 20.7% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.003 · newest: 0.003 · change: 0.000
Affected products
- Rabbitmq Amqp091-Go — versions < 1.13.0