Buffer overflow in Osrg Gobgp
CVE-2026-7735
A vulnerability was found in osrg GoBGP up to 4.3.0. Affected is the function PathAttributeAigp.DecodeFromBytes of the file pkg/packet/bgp/bgp.go of the component AIGP Attribute Parser. Performing a manipulation results in buffer overflow. It is possible to initiate the attack remotely. Upgrading to version 4.4.0 is able to address this issue. The patch is named 51ad1ada06cb41ce47b7066799981816f50b7ced. The affected component should be upgraded.
Vulnerability class: Buffer Overflow
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.3 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L.
EPSS exploit prediction
EPSS: 0.004 (29.6th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 30th percentile — 29.6% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.006 · newest: 0.004 · change: -0.003
Affected products
- Osrg Gobgp — versions 4.0, 4.1, 4.2
Weakness classification (CWE)
References
- github.com/osrg/gobgp/ (Product, product)
- github.com/osrg/gobgp/commit/51ad1ada06cb41ce47b7066799981816f50b7ced (Patch, patch)
- github.com/osrg/gobgp/releases/tag/v4.4.0 (Product, Patch, patch)
- vuldb.com/submit/807600 (VDB Entry, Third Party Advisory, third-party-advisory)
- vuldb.com/vuln/360910 (technical-description, VDB Entry, Third Party Advisory, vdb-entry)
- vuldb.com/vuln/360910/cti (signature, Permissions Required, permissions-required, VDB Entry)
Frequently asked questions
- What is CVE-2026-7735?
- CVE-2026-7735 is a high-severity vulnerability in Osrg Gobgp, classified under Improper Restriction of Operations within the Bounds of a Memory Buffer. CVSS score: 7.3/10. Published 2026-05-04.
- How severe is CVE-2026-7735?
- High severity. CVSS v3 base score is 7.3 out of 10.