Vulnerability in Nm-L2tp Networkmanager-L2tp
CVE-2026-75131
NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.8 (High). Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.
EPSS exploit prediction
EPSS: 0.002 (7.4th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 7th percentile — 7.4% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.002 · newest: 0.002 · change: 0.000
Affected products
Weakness classification (CWE)
References
- github.com/nm-l2tp/NetworkManager-l2tp/security/advisories/GHSA-v2wj-xr2m-xc4j (vendor-advisory)
- www.vulncheck.com/advisories/networkmanager-l2tp-privilege-escalation-via-pppd-… (third-party-advisory)
Frequently asked questions
- What is CVE-2026-75131?
- CVE-2026-75131 is a high-severity vulnerability in Nm-L2tp Networkmanager-L2tp, classified under Argument Injection. CVSS score: 7.8/10. Published 2026-09-23.
- How severe is CVE-2026-75131?
- High severity. CVSS v3 base score is 7.8 out of 10.