Vulnerability in Paymenter

CVE-2026-71537

Paymenter is a free and open-source webshop solution for management of hosting services. Prior to 1.5.7, app/Livewire/Services/Upgrade.php::doUpgrade() relies on Service::upgradable to check for a pending service upgrade and later executes $credit->increment('amount', abs($price)) without DB::transaction or lockForUpdate() spanning those operations. An authenticated customer with an active downgradable service can submit concurrent downgrade requests that each observe no pending upgrade, create separate upgrade records, and increment the same account credit balance, producing multiple spendable refunds for one downgrade. This issue is fixed in version 1.5.7.

Vulnerability class: Race Condition

Published · last modified .

CVSS v3 metric

CVSS v3 base score 6.5 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N.

EPSS exploit prediction

EPSS: 0.003 (25.6th percentile), scored .

Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 26th percentile — 25.6% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2026-71537: held from 0.003 to 0.003.

EPSS over last 30 days · oldest: 0.003 · newest: 0.003 · change: 0.000

Affected products

Weakness classification (CWE)

References

Frequently asked questions

What is CVE-2026-71537?
CVE-2026-71537 is a medium-severity vulnerability in Paymenter, classified under Concurrent Execution using Shared Resource with Improper Synchronization (Race Condition). CVSS score: 6.5/10. Published 2026-09-18.
How severe is CVE-2026-71537?
Medium severity. CVSS v3 base score is 6.5 out of 10.