Vulnerability in Flowiseai Flowise
CVE-2026-69263
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, the mitigation for CVE-2025-8943 blocked -y and --yes flags on npx, but packages/components/nodes/tools/MCP/core.ts denied only PATH, LD_LIBRARY_PATH, DYLD_LIBRARY_PATH, and NODE_OPTIONS by exact environment-variable name. Because npm reads configuration from npm_config_* variables, setting npm_config_yes=true reproduced --yes behavior without using a blocked flag, causing npx to auto-install and execute the named package when a Custom MCP server launched. This issue is fixed in version 3.1.3.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 9.8 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.
EPSS exploit prediction
EPSS: 0.007 (51.7th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 52nd percentile — 51.7% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.007 · newest: 0.007 · change: 0.000
Affected products
- Flowiseai Flowise — versions < 3.1.3
Weakness classification (CWE)
Public proof-of-concept exploits
References
- github.com/FlowiseAI/Flowise/commit/a4c4e4988cded15edf725e762560575b889ae351 (Patch)
- github.com/FlowiseAI/Flowise/pull/6471 (Patch, Issue Tracking)
- github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3 (Patch, Release Notes)
- github.com/FlowiseAI/Flowise/security/advisories/GHSA-xc48-889x-5qmw (Exploit, Vendor Advisory)
Frequently asked questions
- What is CVE-2026-69263?
- CVE-2026-69263 is a critical-severity vulnerability in Flowiseai Flowise, classified under Incomplete List of Disallowed Inputs. CVSS score: 9.8/10. Published 2026-08-04.
- How severe is CVE-2026-69263?
- Critical severity. CVSS v3 base score is 9.8 out of 10.
- Is CVE-2026-69263 known to be exploited?
- 1 public proof-of-concept repositories are indexed. Not currently listed in the CISA KEV catalog.