Auth bypass in Flowiseai Flowise
CVE-2026-69258
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, the unauthenticated POST /api/v1/prediction/:id endpoint accepted an overrideConfig object and unconditionally spread it into internal flowConfig and flowData objects in packages/server/src/utils/buildChatflow.ts and packages/server/src/utils/index.ts without checking apiOverrideStatus. This allowed unauthenticated attackers to inject arbitrary properties into the flow execution context of any public chatflow, overwrite values such as chatId, sessionId, and chatHistory, and control values resolved through $flow.* template variables consumed by flow nodes. This issue is fixed in version 3.1.3.
Vulnerability class: IDOR (Insecure Direct Object Reference)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 9.1 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N.
EPSS exploit prediction
EPSS: 0.007 (51.9th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 52nd percentile — 51.9% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.007 · newest: 0.007 · change: 0.000
Affected products
- Flowiseai Flowise — versions < 3.1.3
Weakness classification (CWE)
References
- github.com/FlowiseAI/Flowise/security/advisories/GHSA-6vh2-wg4h-4vwj (Exploit, Vendor Advisory)
- github.com/FlowiseAI/Flowise/pull/6279 (Patch, Issue Tracking)
- github.com/FlowiseAI/Flowise/commit/23b997ee5ef9e269b628bad0f56f1ecb86bd2fca (Patch)
- github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3 (Patch, Release Notes)
Frequently asked questions
- What is CVE-2026-69258?
- CVE-2026-69258 is a critical-severity vulnerability in Flowiseai Flowise, classified under Authorization Bypass Through User-Controlled Key. CVSS score: 9.1/10. Published 2026-08-04.
- How severe is CVE-2026-69258?
- Critical severity. CVSS v3 base score is 9.1 out of 10.