Vulnerability in Flytohub Flyto-Core
CVE-2026-67427
Flyto2 Core is an execution kernel for automation and AI-agent workflows. Prior to 2.26.6, the workflow engine variable resolver expands ${env.VAR} for any host environment variable without an allowlist or capability policy check, allowing a workflow parameter to bypass the default capability policy denylist for env.get and env.load_dotenv and exfiltrate secrets through allowed modules. This issue is fixed in version 2.26.6.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 8.6 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N.
EPSS exploit prediction
EPSS: 0.004 (38.9th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 39th percentile — 38.9% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.006 · newest: 0.004 · change: -0.001
Affected products
- Flytohub Flyto-Core — versions < 2.26.6
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-67427?
- CVE-2026-67427 is a high-severity vulnerability in Flytohub Flyto-Core, classified under Insufficiently Protected Credentials. CVSS score: 8.6/10. Published 2026-07-29.
- How severe is CVE-2026-67427?
- High severity. CVSS v3 base score is 8.6 out of 10.