Vulnerability in Broadcom Rabbitmq Server
CVE-2026-67405
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, Neither the Web-MQTT handler (deps/rabbitmq_web_mqtt/src/rabbit_web_mqtt_handler.erl:104) nor the Web-STOMP handler (deps/rabbitmq_web_stomp/src/rabbit_web_stomp_handler.erl:102) validates the Origin header on the WebSocket upgrade. Under ssl_cert_login=true, the browser presents the client certificate automatically, so an attacker's JavaScript running in the victim's browser can authenticate as the victim. Preconditions include The non-default configuration use_http_auth=true (Web-STOMP) or ssl_cert_login=true (both plugins) must be enabled. The issue is harmless under the default in-band CONNECT credential configuration.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 8.1 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N.
EPSS exploit prediction
EPSS: 0.001 (1.3th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 1st percentile — 1.3% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.001 · newest: 0.001 · change: -0.000
Affected products
- Broadcom Rabbitmq Server
- Rabbitmq Rabbitmq-Server — versions >= 3.13.0, < 3.13.15, >= 4.0.0, < 4.0.20, >= 4.1.0, < 4.1.11
Weakness classification (CWE)
References
- github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-9c4f-rxxm-88q3 (Vendor Advisory)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6 (Release Notes)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.0 (Release Notes)
Frequently asked questions
- What is CVE-2026-67405?
- CVE-2026-67405 is a high-severity vulnerability in Broadcom Rabbitmq Server, classified under CWE-1385. CVSS score: 8.1/10. Published 2026-09-23.
- How severe is CVE-2026-67405?
- High severity. CVSS v3 base score is 8.1 out of 10.