Vulnerability in Broadcom Rabbitmq Server
CVE-2026-67231
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The trust-store plugin installs a verify_fun that overrides {bad_cert, unknown_ca} / {bad_cert, selfsigned_peer} when the presented cert "matches" a whitelisted one. The match key is extract_issuer_id/1 → public_key:pkix_issuer_id/2 → {IssuerName, SerialNumber} , both fields are taken verbatim from the presented certificate body and contain no public-key, SKI, fingerprint or signature material. is_whitelisted/1 is a pure ets:member lookup; the stored full DER is used only for list/0 display and is never compared against the presented cert. cacerts is [], so the whitelisted cert is never used as a trust anchor for path validation either. TLS client-authentication bypass: an attacker who knows the issuer DN + serial of any whitelisted certificate can connect with a forged self-signed cert. Preconditions include rabbitmq_trust_store plugin enabled and used as the TLS verify_fun Attacker knows or can guess the {Issuer, Serial} of at least one whitelisted cert (non-secret; exposed via CLI/logs/any cert copy). This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
Vulnerability class: Improper Certificate Validation
Published · last modified .
CVSS v3 metric
CVSS v3 base score 9.1 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N.
EPSS exploit prediction
EPSS: 0.002 (13.6th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 14th percentile — 13.6% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.002 · newest: 0.002 · change: -0.000
Affected products
- Broadcom Rabbitmq Server
- Rabbitmq Rabbitmq-Server — versions >= 3.13.0, < 3.13.15, >= 4.0.0, < 4.0.20, >= 4.1.0, < 4.1.11
Weakness classification (CWE)
References
- github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-cw8c-4m83-9c6w (Vendor Advisory)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6 (Release Notes)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.0 (Release Notes)
Frequently asked questions
- What is CVE-2026-67231?
- CVE-2026-67231 is a critical-severity vulnerability in Broadcom Rabbitmq Server, classified under Improper Certificate Validation. CVSS score: 9.1/10. Published 2026-09-23.
- How severe is CVE-2026-67231?
- Critical severity. CVSS v3 base score is 9.1 out of 10.