Resource exhaustion in Broadcom Rabbitmq Server
CVE-2026-67228
RabbitMQ is a messaging and streaming broker. Prior to versions 4.2.7 and 4.3.1, The runtime-parameters lookup path coerces the URL :component segment to an atom with rabbit_data_coercion:to_atom/1 in lookup_component/1 (deps/rabbit/src/rabbit_runtime_parameters.erl), creating a new atom for any previously unseen value. A safe helper, rabbit_registry:binary_to_type/1, which uses binary_to_existing_atom with a catch, already exists but is not used at this call site. lookup_component/1 calls rabbit_data_coercion:to_atom(Component) on the :component segment of the request URL, converting an attacker-supplied string into a new atom. Because the Erlang atom table is bounded and atoms are never garbage collected, an authorized policymaker issuing roughly one million requests with distinct component values can exhaust the atom table and crash the node, resulting in a denial of service. Preconditions include Exploitation requires policymaker privileges and roughly one million requests.. This issue is fixed in versions 4.2.7 and 4.3.1.
Vulnerability class: DoS (Denial of Service)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 4.9 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H.
EPSS exploit prediction
EPSS: 0.003 (24.6th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 25th percentile — 24.6% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.003 · newest: 0.003 · change: +0.000
Affected products
- Broadcom Rabbitmq Server
- Rabbitmq Rabbitmq-Server — versions >= 4.2.0, < 4.2.7, >= 4.3.0, < 4.3.1
Weakness classification (CWE)
References
- github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-73qp-fwh4-2q5g (Vendor Advisory)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.7 (Release Notes)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.1 (Release Notes)
Frequently asked questions
- What is CVE-2026-67228?
- CVE-2026-67228 is a medium-severity vulnerability in Broadcom Rabbitmq Server, classified under Uncontrolled Resource Consumption. CVSS score: 4.9/10. Published 2026-09-23.
- How severe is CVE-2026-67228?
- Medium severity. CVSS v3 base score is 4.9 out of 10.