Vulnerability in Broadcom Rabbitmq Server
CVE-2026-67221
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The AMQP 0-9-1 shovel calls amqp_uri:remove_credentials before storing its connection URI, but the AMQP 1.0 shovel stores the raw URI including the password. The stored URI is visible via GET /api/shovels and via rabbitmqctl shovel_status. Preconditions include The Shovel plugin must be in use with AMQP 1.0 shovels configured using URI-embedded credentials. Reading the exposed status requires the monitoring tag.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 4.9 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N.
EPSS exploit prediction
EPSS: 0.002 (8.7th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 9th percentile — 8.7% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.002 · newest: 0.002 · change: -0.000
Affected products
- Broadcom Rabbitmq Server
- Rabbitmq Rabbitmq-Server — versions >= 3.13.0, < 3.13.15, >= 4.0.0, < 4.0.20, >= 4.1.0, < 4.1.11
Weakness classification (CWE)
References
- github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-x5h5-588r-cv55 (Vendor Advisory)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6 (Release Notes)
Frequently asked questions
- What is CVE-2026-67221?
- CVE-2026-67221 is a medium-severity vulnerability in Broadcom Rabbitmq Server, classified under Cleartext Storage of Sensitive Information. CVSS score: 4.9/10. Published 2026-09-23.
- How severe is CVE-2026-67221?
- Medium severity. CVSS v3 base score is 4.9 out of 10.