Auth bypass in Arcadedata Arcadedb
CVE-2026-65831
ArcadeDB is a Multi-Model DBMS. Prior to 26.7.1, a reader-role user can submit POST /api/v1/command/{database} with language: js because PolyglotQueryEngine.command, PolyglotQueryEngine.analyze, and PolyglotQueryEngine.registerFunctions do not enforce database-administrator authorization. GraalPolyglotEngine also permits scripts to bypass the allowedPackages whitelist by reflecting from the bound database object through database.getClass().getClassLoader().loadClass to arbitrary host classes. These cooperating defects allow a read-only database user to read arbitrary host files outside the database scope. Process creation is already blocked, so OS command execution is not confirmed. The issue is distinct from CVE-2026-44221, CVE-2026-54076, and CVE-2026-54077. This issue is fixed in version 26.7.1.
Vulnerability class: Privilege Escalation
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.7 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N.
EPSS exploit prediction
EPSS: 0.006 (48.6th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 49th percentile — 48.6% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.006 · newest: 0.006 · change: 0.000
Affected products
- Arcadedata Arcadedb — versions < 26.7.1
- Com.arcadedb Arcadedb-Server — versions < 26.7.1
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-65831?
- CVE-2026-65831 is a high-severity vulnerability in Arcadedata Arcadedb, classified under Improper Privilege Management. CVSS score: 7.7/10. Published 2026-09-15.
- How severe is CVE-2026-65831?
- High severity. CVSS v3 base score is 7.7 out of 10.