XSS in Open-Wanderer Wanderer
CVE-2026-62346
Wanderer is a self-hosted trail database for saving and sharing adventures. Prior to 0.19.3, an authenticated local user can submit crafted waypoint.name and waypoint.icon values that the trail elevation graph interpolates into an innerHTML template in web/src/lib/vendor/maplibre-elevation-profile/elevationprofile.ts without HTML encoding or icon validation. A victim viewing the elevation profile executes the attacker-controlled script in their browser. Separately, federated waypoints can deliver the same malicious fields across instances without requiring the attacker to have a local account on the receiving instance. The script can expose session data or perform actions in the victim's context. This issue is fixed in version 0.19.3.
Vulnerability class: XSS (Cross-Site Scripting)
Published .
CVSS v3 metric
CVSS v3 base score 7.6 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N.
EPSS exploit prediction
No EPSS score from FIRST.org yet. New CVEs usually get one within a few days; no score means no signal yet, not low risk. How EPSS works.
Affected products
- Open-Wanderer Wanderer — versions < 0.19.3
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-62346?
- CVE-2026-62346 is a high-severity vulnerability in Open-Wanderer Wanderer, classified under Cross-site Scripting. CVSS score: 7.6/10. Published 2026-11-06.
- How severe is CVE-2026-62346?
- High severity. CVSS v3 base score is 7.6 out of 10.