Vulnerability in Owasp-Modsecurity Modsecurity
CVE-2026-61813
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Prior to 2.9.15 and 3.0.17, the HttpsClient::download function in src/utils/https_client.cc sets libcurl CURLOPT_SSL_VERIFYHOST to 1 instead of the strict value 2L. Under adversary-in-the-middle and TLS interception conditions, this non-strict setting may weaken TLS peer identity validation and increase the risk of accepting a certificate for an unintended host. End-to-end exploitation is non-trivial in typical environments. This issue is fixed in versions 2.9.15 and 3.0.17.
Vulnerability class: Improper Certificate Validation
Published .
CVSS v3 metric
CVSS v3 base score 3.7 (Low). Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N.
EPSS exploit prediction
No EPSS score from FIRST.org yet. New CVEs usually get one within a few days; no score means no signal yet, not low risk. How EPSS works.
Affected products
- Owasp-Modsecurity Modsecurity — versions < 2.9.15, >= 3.0.0, < 3.0.17
Weakness classification (CWE)
References
- https://github.com/owasp-modsecurity/ModSecurity/commit/cce204806430e4848327aadeb9113e654631a0c1
- https://github.com/owasp-modsecurity/ModSecurity/commit/edca70d853bfb725325137fa40d178beebc324fc
- https://github.com/owasp-modsecurity/ModSecurity/releases/tag/v2.9.15
- https://github.com/owasp-modsecurity/ModSecurity/releases/tag/v3.0.17
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-2vqc-36qp-ccmw
Frequently asked questions
- What is CVE-2026-61813?
- CVE-2026-61813 is a low-severity vulnerability in Owasp-Modsecurity Modsecurity, classified under Improper Certificate Validation. CVSS score: 3.7/10. Published 2026-11-05.
- How severe is CVE-2026-61813?
- Low severity. CVSS v3 base score is 3.7 out of 10.