Path Traversal in Composer

CVE-2026-59944

Composer is a dependency Manager for the PHP language. From 1.0 until 2.2.30 and from 2.3.0 until 2.10.3, a malicious or compromised dependency can bypass the earlier CVE-2026-59946 binary-path hardening because Composer validates literal parent-directory segments only during dependency resolution, while the symlink and installed-metadata paths described by the advisory skip that validation. A package can ship an in-package binary symlink that resolves outside its installation directory, or attacker-influenced vendor/composer/installed.json metadata can provide an escaping binary path during a reinstall or regeneration of missing vendor/bin entries. The installed-metadata path is reachable only when the vendor directory was not populated by the same validated install run, such as when it is restored from an untrusted cache, copied from an earlier build stage, carried over from an older Composer run, or writable by a lower-trust build step. Composer can follow the path, change the external target's permissions to make it world-readable and executable, and create a runnable vendor/bin proxy to that external file. The issue does not directly read or transmit data and does not by itself provide remote code execution. This issue is fixed in versions 2.2.30 and 2.10.3.

Vulnerability class: Path Traversal (Directory Traversal)

Published · last modified .

CVSS v3 metric

CVSS v3 base score 6.1 (Medium). Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N.

EPSS exploit prediction

EPSS: 0.005 (40.7th percentile), scored .

Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 41st percentile — 40.7% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2026-59944: held from 0.003 to 0.005.

EPSS over last 30 days · oldest: 0.003 · newest: 0.005 · change: +0.001

Affected products

  • Composer — versions >= 1.0.0, < 2.2.30, >= 2.3.0, < 2.10.3

Weakness classification (CWE)

References

Frequently asked questions

What is CVE-2026-59944?
CVE-2026-59944 is a medium-severity vulnerability in Composer, classified under Path Traversal. CVSS score: 6.1/10. Published 2026-09-16.
How severe is CVE-2026-59944?
Medium severity. CVSS v3 base score is 6.1 out of 10.