XSS in Comfy-Org Comfyui
CVE-2026-56670
ComfyUI is a modular diffusion model GUI, api and backend with a graph/nodes interface. Prior to 0.28.0, the /view endpoint served uploaded SVG files inline because image/svg+xml and related XML content types were absent from the dangerous-content-type handling, allowing stored cross-site scripting in the ComfyUI origin. This issue is fixed in version 0.28.0.
Vulnerability class: XSS (Cross-Site Scripting)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 8.2 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N.
EPSS exploit prediction
EPSS: 0.004 (33.9th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 34th percentile — 33.9% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.004 · newest: 0.004 · change: 0.000
Affected products
- Comfy-Org Comfyui — versions < 0.28.0
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-56670?
- CVE-2026-56670 is a high-severity vulnerability in Comfy-Org Comfyui, classified under Cross-site Scripting. CVSS score: 8.2/10. Published 2026-07-31.
- How severe is CVE-2026-56670?
- High severity. CVSS v3 base score is 8.2 out of 10.