Auth bypass in Laravel-Backpack Crud
CVE-2026-54180
backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. From 6.0.0 until 6.8.14 and 7.0.38, the Update, Delete, and Reorder operations resolve records from the unscoped model query instead of the query configured through addClause() or addBaseClause(). An authenticated user who knows or guesses an out-of-scope record primary key can therefore modify, delete, or reorder records hidden by tenant, ownership, or other row-level access-control scopes. Applications that do not rely on CRUD query clauses for authorization are not affected by this specific bypass. The fix routes all three write operations through getModelWithCrudPanelQuery(), matching the scoped list and read behavior. This issue is fixed in versions 6.8.14 and 7.0.38.
Vulnerability class: IDOR (Insecure Direct Object Reference)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.6 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L.
EPSS exploit prediction
EPSS: 0.005 (39.9th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 40th percentile — 39.9% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.005 · newest: 0.005 · change: 0.000
Affected products
- Laravel-Backpack Crud — versions >= 6.0.0, < 6.8.14, >= 7.0.0, < 7.0.38
Weakness classification (CWE)
References
- github.com/Laravel-Backpack/CRUD/security/advisories/GHSA-vgmv-8xjc-6rch
- github.com/Laravel-Backpack/CRUD/pull/5991
- github.com/Laravel-Backpack/CRUD/pull/5994
- github.com/Laravel-Backpack/CRUD/commit/76c3a6e50e3fbd6d5f633208da5b04acb8322969
- github.com/Laravel-Backpack/CRUD/commit/dd25c2086b8ea2cb765993b65876c66ab824eef0
- github.com/Laravel-Backpack/CRUD/releases/tag/6.8.14
- github.com/Laravel-Backpack/CRUD/releases/tag/7.0.38
Frequently asked questions
- What is CVE-2026-54180?
- CVE-2026-54180 is a high-severity vulnerability in Laravel-Backpack Crud, classified under Authorization Bypass Through User-Controlled Key. CVSS score: 7.6/10. Published 2026-09-14.
- How severe is CVE-2026-54180?
- High severity. CVSS v3 base score is 7.6 out of 10.