Improper input validation in Eugeny Russh
CVE-2026-48110
Russh is a Rust SSH client & server library. From version 0.34.0 to before version 0.61.0, several russh client and server message handlers decoded attacker-controlled SSH strings, name-lists, and byte fields into owned allocations before applying field-specific bounds. A remote SSH peer could send oversized, high-fanout, or malformed length-prefixed fields and make the library allocate, attempt to allocate, or split data before rejecting input that should have been rejected earlier. This issue has been patched in version 0.61.0.
Vulnerability class: Drupalgeddon 2 (CVE-2018-7600)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.5 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.
EPSS exploit prediction
EPSS: 0.004 (30.5th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 31st percentile — 30.5% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.005 · newest: 0.004 · change: -0.001
Affected products
- Eugeny Russh — versions >= 0.34.0, < 0.61.0
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-48110?
- CVE-2026-48110 is a high-severity vulnerability in Eugeny Russh, classified under Improper Input Validation. CVSS score: 7.5/10. Published 2026-06-10.
- How severe is CVE-2026-48110?
- High severity. CVSS v3 base score is 7.5 out of 10.