Improper input validation in Eugeny Russh
CVE-2026-48107
Russh is a Rust SSH client & server library. From version 0.37.0 to before version 0.61.0, in the russh client keyboard-interactive authentication path, a malicious SSH server could send a USERAUTH_INFO_REQUEST with an attacker-controlled prompt count, and the client would use that raw count directly in Vec::with_capacity(...) before validating that enough prompt data was actually present in the packet. This issue has been patched in version 0.61.0.
Vulnerability class: Drupalgeddon 2 (CVE-2018-7600)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 6.5 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H.
EPSS exploit prediction
EPSS: 0.002 (14.1th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 14th percentile — 14.1% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.004 · newest: 0.002 · change: -0.002
Affected products
- Eugeny Russh — versions >= 0.37.0, < 0.61.0
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-48107?
- CVE-2026-48107 is a medium-severity vulnerability in Eugeny Russh, classified under Improper Input Validation. CVSS score: 6.5/10. Published 2026-06-10.
- How severe is CVE-2026-48107?
- Medium severity. CVSS v3 base score is 6.5 out of 10.