Vulnerability in Fluent-Plugins-Nursery Fluent-Plugin-Opentelemetry
CVE-2026-44163
fluent-plugin-opentelemetry is a Fluentd input and output plugin for forwarding OpenTelemetry Protocol data. Prior to 0.5.3, the in_opentelemetry HTTP input read the entire incoming request body and decompressed payloads into memory without enforcing maximum size thresholds. When an OpenTelemetry ingestion endpoint was exposed to an untrusted network, an attacker could send an excessively large request or a highly compressed payload that expanded in memory. The resulting memory exhaustion could cause the operating system to terminate the Fluentd process, disrupting all log collection and forwarding on the affected node. This issue is fixed in version 0.5.3.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 5.3 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L.
EPSS exploit prediction
EPSS: 0.004 (36.1th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 36th percentile — 36.1% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.004 · newest: 0.004 · change: 0.000
Affected products
- Fluent-Plugins-Nursery Fluent-Plugin-Opentelemetry — versions < 0.5.3
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-44163?
- CVE-2026-44163 is a medium-severity vulnerability in Fluent-Plugins-Nursery Fluent-Plugin-Opentelemetry, classified under Improper Handling of Highly Compressed Data (Data Amplification). CVSS score: 5.3/10. Published 2026-09-15.
- How severe is CVE-2026-44163?
- Medium severity. CVSS v3 base score is 5.3 out of 10.