Vulnerability in Fluent Fluent-Plugin-S3
CVE-2026-44162
fluent-plugin-s3 is an Amazon S3 input and output plugin for Fluentd. From 0.7.0 to 1.8.4, the in_s3 input plugin reads the entire decompressed payload of gzip, lzma2, and lzop objects into memory without enforcing a decompression_size_limit. An attacker with permission to upload objects to the monitored S3 bucket can provide a highly compressed object that expands excessively when Fluentd processes it. The resulting memory exhaustion can cause the operating system to terminate the Fluentd process and disrupt all log collection on the affected node. This issue is fixed in version 1.8.5.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 2.7 (Low). Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L.
EPSS exploit prediction
EPSS: 0.005 (41.6th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 42nd percentile — 41.6% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.005 · newest: 0.005 · change: 0.000
Affected products
- Fluent Fluent-Plugin-S3 — versions >= 0.7.0, < 1.8.5
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-44162?
- CVE-2026-44162 is a low-severity vulnerability in Fluent Fluent-Plugin-S3, classified under Improper Handling of Highly Compressed Data (Data Amplification). CVSS score: 2.7/10. Published 2026-09-14.
- How severe is CVE-2026-44162?
- Low severity. CVSS v3 base score is 2.7 out of 10.