Vulnerability in Osrg Gobgp

CVE-2026-41643

GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. Prior to version 4.3.0, a remote Denial of Service (DoS) vulnerability exists in GoBGP where a malformed BGP UPDATE message can trigger a runtime error: index out of range panic. This occurs during the processing of 4-byte AS attributes when the message structure causes an internal slice index shift that is not properly handled. This issue has been patched in version 4.3.0.

Published · last modified .

CVSS v3 metric

CVSS v3 base score 7.5 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.

EPSS exploit prediction

EPSS: 0.005 (45.3th percentile), scored .

Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 45th percentile — 45.3% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2026-41643: held from 0.006 to 0.005.

EPSS over last 30 days · oldest: 0.006 · newest: 0.005 · change: -0.001

Affected products

Weakness classification (CWE)

References

Frequently asked questions

What is CVE-2026-41643?
CVE-2026-41643 is a high-severity vulnerability in Osrg Gobgp, classified under Improper Validation of Array Index. CVSS score: 7.5/10. Published 2026-05-07.
How severe is CVE-2026-41643?
High severity. CVSS v3 base score is 7.5 out of 10.