Buffer overflow in Apache Apr-Util
CVE-2026-34501
Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client. This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3. Users are recommended to upgrade to version 1.6.4, which fixes the issue.
Vulnerability class: Buffer Overflow
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.5 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.
EPSS exploit prediction
EPSS: 0.005 (43.5th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 43rd percentile — 43.5% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.005 · newest: 0.005 · change: 0.000
Affected products
- Apache Apr-Util
- Apache Software Foundation Portable Runtime Utility — versions 1.6.0
Weakness classification (CWE)
References
- lists.apache.org/thread/o8h6c7cq86fplxlnry6c3rn9x0ovq8mv (vendor-advisory, Mailing List, Vendor Advisory)
- af854a3a-2127-422b-91ae-364da2661108 (Mailing List, Third Party Advisory)
Frequently asked questions
- What is CVE-2026-34501?
- CVE-2026-34501 is a high-severity vulnerability in Apache Apr-Util, classified under Heap-based Buffer Overflow. CVSS score: 7.5/10. Published 2026-08-06.
- How severe is CVE-2026-34501?
- High severity. CVSS v3 base score is 7.5 out of 10.