RCE in Geonode
CVE-2026-33050
GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. Prior to 5.1.0, a crafted vector file layer name supplied during upload allows a low-privileged remote user to inject shell syntax and execute arbitrary operating-system commands on the GeoNode server. This issue is fixed in version 5.1.0.
Vulnerability class: Command Injection (OS Command Injection)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 8.8 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.
EPSS exploit prediction
No EPSS score from FIRST.org yet. New CVEs usually get one within a few days; no score means no signal yet, not low risk. How EPSS works.
Affected products
- Geonode — versions < 5.1.0
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-33050?
- CVE-2026-33050 is a high-severity vulnerability in Geonode, classified under OS Command Injection. CVSS score: 8.8/10. Published 2026-11-06.
- How severe is CVE-2026-33050?
- High severity. CVSS v3 base score is 8.8 out of 10.