Vulnerability in Parseablehq Parseable
CVE-2026-32641
Parseable is a log analytics platform built for high-volume data ingestion and analysis. Prior to 3.0.0, src/handlers/http/middleware.rs uses unwrap() while parsing the x-amz-firehose-common-attributes header before authentication. A remote unauthenticated attacker can supply non-UTF-8 header data, malformed JSON, or invalid derived header values that trigger a Rust panic and interrupt request handling, allowing repeated requests to deny service or cause container restart loops. This issue is fixed in version 3.0.0.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 7.5 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.
EPSS exploit prediction
EPSS: 0.009 (60.4th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 60th percentile — 60.4% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.009 · newest: 0.009 · change: 0.000
Affected products
- Parseablehq Parseable — versions < 3.0.0
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-32641?
- CVE-2026-32641 is a high-severity vulnerability in Parseablehq Parseable, classified under CWE-248. CVSS score: 7.5/10. Published 2026-09-18.
- How severe is CVE-2026-32641?
- High severity. CVSS v3 base score is 7.5 out of 10.