Vulnerability in Apache Apr-Util
CVE-2026-32327
A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 9.1 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H.
EPSS exploit prediction
EPSS: 0.005 (39.8th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 40th percentile — 39.8% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.005 · newest: 0.005 · change: 0.000
Affected products
Weakness classification (CWE)
References
- lists.apache.org/thread/hq27vj8yfno9tkwv0fpj6jksfzgxvth1 (vendor-advisory, Mailing List, Vendor Advisory)
- af854a3a-2127-422b-91ae-364da2661108 (Mailing List, Third Party Advisory)
Frequently asked questions
- What is CVE-2026-32327?
- CVE-2026-32327 is a critical-severity vulnerability in Apache Apr-Util, classified under Uncontrolled Recursion. CVSS score: 9.1/10. Published 2026-08-06.
- How severe is CVE-2026-32327?
- Critical severity. CVSS v3 base score is 9.1 out of 10.