Auth bypass in Hwk-Fr Advanced Custom Fields: Extended

CVE-2026-2839

The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (`wp_ajax_nopriv_*`) that fail to implement proper `current_user_can()` authorization checks. While these handlers use ACF's `acf_verify_ajax()` function to validate cryptographic nonces, the `acf_nonce` values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.

Vulnerability class: Broken Access Control

Published · last modified .

CVSS v3 metric

CVSS v3 base score 5.3 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N.

EPSS exploit prediction

EPSS: 0.003 (19.8th percentile), scored .

Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 20th percentile — 19.8% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

The 30-day trend appears once there are two daily scores.

Affected products

Weakness classification (CWE)

References

Frequently asked questions

What is CVE-2026-2839?
CVE-2026-2839 is a medium-severity vulnerability in Hwk-Fr Advanced Custom Fields: Extended, classified under Missing Authorization. CVSS score: 5.3/10. Published 2026-10-28.
How severe is CVE-2026-2839?
Medium severity. CVSS v3 base score is 5.3 out of 10.