XSS in AWS Maplibre-Gl-Js-Amplify
CVE-2026-121652
Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later.
Vulnerability class: XSS (Cross-Site Scripting)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 5.4 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N.
EPSS exploit prediction
No EPSS score from FIRST.org yet. New CVEs usually get one within a few days; no score means no signal yet, not low risk. How EPSS works.
Affected products
Weakness classification (CWE)
References
- ff89ba41-3aa1-4d27-914a-91399e9639e5 (release-notes, patch)
- ff89ba41-3aa1-4d27-914a-91399e9639e5 (third-party-advisory)
- ff89ba41-3aa1-4d27-914a-91399e9639e5 (vendor-advisory)
Frequently asked questions
- What is CVE-2026-121652?
- CVE-2026-121652 is a medium-severity vulnerability in AWS Maplibre-Gl-Js-Amplify, classified under Cross-site Scripting. CVSS score: 5.4/10. Published 2026-11-03.
- How severe is CVE-2026-121652?
- Medium severity. CVSS v3 base score is 5.4 out of 10.