RCE in Welcart E-Commerce Plugin
CVE-2026-120597
A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Vulnerability class: XSS (Cross-Site Scripting)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 4.3 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N.
EPSS exploit prediction
No EPSS score from FIRST.org yet. New CVEs usually get one within a few days; no score means no signal yet, not low risk. How EPSS works.
Affected products
- Welcart E-Commerce Plugin — versions 2.12.0, 2.12.1, 2.12.2
Weakness classification (CWE)
References
- vuldb.com/vuln/429933 (technical-description, vdb-entry)
- vuldb.com/vuln/429933/cti (signature, permissions-required)
- vuldb.com/cve/CVE-2026-120597 (third-party-advisory)
- vuldb.com/submit/1039186 (third-party-advisory)
- github.com/bevennyamande/welcart-poc (exploit)
- wordpress.org/plugins/usc-e-shop/ (patch)
Frequently asked questions
- What is CVE-2026-120597?
- CVE-2026-120597 is a medium-severity vulnerability in Welcart E-Commerce Plugin, classified under Cross-site Scripting. CVSS score: 4.3/10. Published 2026-11-02.
- How severe is CVE-2026-120597?
- Medium severity. CVSS v3 base score is 4.3 out of 10.