XSS in Ckeditor Ckeditor5
CVE-2026-116687
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 29.0.0 until 47.7.4 and 48.5.1, specially crafted markup can trigger cross-site scripting when General HTML Support is enabled and specifically configured to allow object content. Processing that content can execute attacker-controlled JavaScript in a browser context isolated from the origin of the application embedding the editor. This issue is fixed in versions 47.7.4 and 48.5.1.
Vulnerability class: XSS (Cross-Site Scripting)
Published .
CVSS v3 metric
CVSS v3 base score 3.1 (Low). Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N.
EPSS exploit prediction
No EPSS score from FIRST.org yet. New CVEs usually get one within a few days; no score means no signal yet, not low risk. How EPSS works.
Affected products
- Ckeditor Ckeditor5 — versions >= 29.0.0, < 47.7.4, >= 48.0.0, < 48.5.1
Weakness classification (CWE)
References
- github.com/ckeditor/ckeditor5/security/advisories/GHSA-v6mg-96c6-gmpq
- github.com/ckeditor/ckeditor5/commit/4d9c5bb34f63cd956d15ccafbe584e14280c86a0
- github.com/ckeditor/ckeditor5/commit/a750e38635db6a18c5b11599c09f4fd702850423
- github.com/ckeditor/ckeditor5/releases/tag/v47.7.4
- github.com/ckeditor/ckeditor5/releases/tag/v48.5.1
Frequently asked questions
- What is CVE-2026-116687?
- CVE-2026-116687 is a low-severity vulnerability in Ckeditor Ckeditor5, classified under Cross-site Scripting. CVSS score: 3.1/10. Published 2026-10-27.
- How severe is CVE-2026-116687?
- Low severity. CVSS v3 base score is 3.1 out of 10.