Vulnerability in MongoDB, Inc. Mongosh
CVE-2026-115930
The MongoDB Shell (mongosh) relies on Node.js as a third-party runtime that carries its own TLS root certificate store. This certificate store has the recoverable eMudhra intermediate CA certificates. This issue impacts MongoDB Shell (mongosh) versions prior to 2.14.0 and can be resolved by updating to mongosh 2.14.0 which bundles Node.js 24.22.1 or later. If mongosh is installed through npm, it uses the Node.js runtime installed on the host; update that runtime separately.
Vulnerability class: Improper Certificate Validation
Published · last modified .
CVSS v3 metric
CVSS v3 base score 6.8 (Medium). Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N.
EPSS exploit prediction
No EPSS score from FIRST.org yet. New CVEs usually get one within a few days; no score means no signal yet, not low risk. How EPSS works.
Affected products
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-115930?
- CVE-2026-115930 is a medium-severity vulnerability in MongoDB, Inc. Mongosh, classified under Improper Certificate Validation. CVSS score: 6.8/10. Published 2026-10-26.
- How severe is CVE-2026-115930?
- Medium severity. CVSS v3 base score is 6.8 out of 10.