Improper input validation in Vllm-Project Vllm
CVE-2026-115915
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
Vulnerability class: Drupalgeddon 2 (CVE-2018-7600)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 8.1 (High). Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H.
EPSS exploit prediction
No EPSS score from FIRST.org yet. New CVEs usually get one within a few days; no score means no signal yet, not low risk. How EPSS works.
Affected products
- Vllm-Project Vllm — versions < 0.32.0
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2026-115915?
- CVE-2026-115915 is a high-severity vulnerability in Vllm-Project Vllm, classified under Improper Input Validation. CVSS score: 8.1/10. Published 2026-10-26.
- How severe is CVE-2026-115915?
- High severity. CVSS v3 base score is 8.1 out of 10.