Vulnerability in Onelogin Ruby-Saml
CVE-2025-66568
The ruby-saml library implements the client side of an SAML authorization. Versions up to and including 1.12.4, are vulnerable to authentication bypass through the libxml2 canonicalization process used by Nokogiri for document transformation, which allows an attacker to execute a Signature Wrapping attack. When libxml2’s canonicalization is invoked on an invalid XML input, it may return an empty string rather than a canonicalized node. ruby-saml then proceeds to compute the DigestValue over this empty string, treating it as if canonicalization succeeded. This issue is fixed in version 1.18.0.
Published · last modified .
CVSS v3 metric
CVSS v3 base score 9.1 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N.
EPSS exploit prediction
EPSS: 0.003 (16.4th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 16th percentile — 16.4% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.002 · newest: 0.003 · change: +0.000
Affected products
- Onelogin Ruby-Saml
- Saml-Toolkits Ruby-Saml — versions < 1.18.0
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2025-66568?
- CVE-2025-66568 is a critical-severity vulnerability in Onelogin Ruby-Saml, classified under Improper Verification of Cryptographic Signature. CVSS score: 9.1/10. Published 2025-12-09.
- How severe is CVE-2025-66568?
- Critical severity. CVSS v3 base score is 9.1 out of 10.