Vulnerability in Apache Zookeeper
CVE-2025-58457
Improper permission check in ZooKeeper AdminServer lets authorized clients to run snapshot and restore command with insufficient permissions. This issue affects Apache ZooKeeper: from 3.9.0 before 3.9.4. Users are recommended to upgrade to version 3.9.4, which fixes the issue. The issue can be mitigated by disabling both commands (via admin.snapshot.enabled and admin.restore.enabled), disabling the whole AdminServer interface (via admin.enableServer), or ensuring that the root ACL does not provide open permissions. (Note that ZooKeeper ACLs are not recursive, so this does not impact operations on child nodes besides notifications from recursive watches.)
Published · last modified .
CVSS v3 metric
CVSS v3 base score 4.3 (Medium). Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N.
EPSS exploit prediction
EPSS: 0.003 (25.1th percentile), scored .
Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 25th percentile — 25.1% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.
EPSS over last 30 days · oldest: 0.003 · newest: 0.003 · change: +0.000
Affected products
- Apache Zookeeper
- Apache Software Foundation Zookeeper — versions 3.9.0
Weakness classification (CWE)
Public proof-of-concept exploits
References
- lists.apache.org/thread/r5yol0kkhx2fzw22pxk1ozwm3oc6yxrx (vendor-advisory, Mailing List, Vendor Advisory)
- af854a3a-2127-422b-91ae-364da2661108
Frequently asked questions
- What is CVE-2025-58457?
- CVE-2025-58457 is a medium-severity vulnerability in Apache Zookeeper, classified under Improper Handling of Insufficient Permissions or Privileges. CVSS score: 4.3/10. Published 2025-09-24.
- How severe is CVE-2025-58457?
- Medium severity. CVSS v3 base score is 4.3 out of 10.
- Is CVE-2025-58457 known to be exploited?
- 1 public proof-of-concept repositories are indexed. Not currently listed in the CISA KEV catalog.