Vulnerability in Jupyterlab Jupyterlab-Desktop
CVE-2025-54991
JupyterLab Desktop is the cross-platform desktop application for JupyterLab. Prior to 4.6.2-1, JupyterLab Desktop for macOS declared the com.apple.security.cs.allow-dyld-environment-variables entitlement, allowing the dynamic linker to honor DYLD_INSERT_LIBRARIES despite the hardened runtime. An attacker who can already execute code as the current user can load an arbitrary dynamic library into the JupyterLab Desktop process and inherit TCC permissions previously granted to the application, including access to protected Documents, Desktop, or Downloads folders without another macOS prompt. Exploitation requires existing local code execution and prior TCC grants; it does not provide initial or remote code execution. Windows and Linux are not affected. This vulnerability is fixed in 4.6.2-1.
Published .
CVSS v3 metric
CVSS v3 base score 5.5 (Medium). Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N.
EPSS exploit prediction
No EPSS score from FIRST.org yet. New CVEs usually get one within a few days; no score means no signal yet, not low risk. How EPSS works.
Affected products
- Jupyterlab Jupyterlab-Desktop — versions < 4.6.2-1
Weakness classification (CWE)
References
Frequently asked questions
- What is CVE-2025-54991?
- CVE-2025-54991 is a medium-severity vulnerability in Jupyterlab Jupyterlab-Desktop, classified under CWE-250. CVSS score: 5.5/10. Published 2026-11-06.
- How severe is CVE-2025-54991?
- Medium severity. CVSS v3 base score is 5.5 out of 10.