Resource exhaustion in Saml-Toolkits Ruby-Saml

CVE-2025-54572

The Ruby SAML library is for implementing the client side of a SAML authorization. In versions 1.18.0 and below, a denial-of-service vulnerability exists in ruby-saml even with the message_max_bytesize setting configured. The vulnerability occurs because the SAML response is validated for Base64 format prior to checking the message size, leading to potential resource exhaustion. This is fixed in version 1.18.1.

Vulnerability class: DoS (Denial of Service)

Published · last modified .

EPSS exploit prediction

EPSS: 0.004 (37.0th percentile), scored .

Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 37th percentile — 37.0% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2025-54572: held from 0.004 to 0.004.

EPSS over last 30 days · oldest: 0.004 · newest: 0.004 · change: +0.000

Affected products

Weakness classification (CWE)

Public proof-of-concept exploits

References

Frequently asked questions

What is CVE-2025-54572?
CVE-2025-54572 is a vulnerability in Saml-Toolkits Ruby-Saml, classified under Uncontrolled Resource Consumption. Published 2025-07-30.
Is CVE-2025-54572 known to be exploited?
2 public proof-of-concept repositories are indexed. Not currently listed in the CISA KEV catalog.