Vulnerability in Apache Apr-Util

CVE-2025-49506

APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

Published · last modified .

CVSS v3 metric

CVSS v3 base score 7.5 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N.

EPSS exploit prediction

EPSS: 0.004 (32.0th percentile), scored .

Very low probability of exploitation in the next 30 days; routine patching cadence is appropriate. 32nd percentile — 32.0% of CVEs in the catalogue have a lower EPSS than this one. How to read EPSS.

EPSS trend (30 days)EPSS over the last 30 days for CVE-2025-49506: held from 0.004 to 0.004.

EPSS over last 30 days · oldest: 0.004 · newest: 0.004 · change: 0.000

Affected products

Weakness classification (CWE)

References

Frequently asked questions

What is CVE-2025-49506?
CVE-2025-49506 is a high-severity vulnerability in Apache Apr-Util, classified under CWE-208. CVSS score: 7.5/10. Published 2026-08-06.
How severe is CVE-2025-49506?
High severity. CVSS v3 base score is 7.5 out of 10.